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About this manual

Introduction

This manual provides an introduction to the basic functionality available in WYSIWYG 
and is designed to get you started using the program. It is recommended that you use 
this manual while running the Quick Start Tutorial. The tutorial provides both video and 
audio elements to help you progress through the 13 lessons. This guide contains a text 
version of the audio portion of the tutorial, along with accompanying graphics. It also 
contains some additional information that is not included in the tutorials.

You can access the tutorial from the WYSIWYG Install panel. 

Note: To view the video portion of the Quick Start Tutorial, you must have the 
TechSmith Screen Capture Codec (TSCC) installed on your machine. This codec is 
available on the WYSIWYG CD for your convenience.

Text conventions

The following text conventions are used in this manual:

Menus and menu commands appear in Arial bold. For example, “from the 
Library menu, choose Browse Library.”
User interface elements such as buttons, tools, shortcuts, and dialog boxes 
appear in Tahoma Oblique. For example, “to draw a riser, click the Riser tool on 
the Draw toolbar.”
Keyboard keys are indicated in ALL CAPS. For example, “press the TAB key to 
enter the missing coordinate.”
References to manuals appear in italic font. For example, “for additional 
information on rendering, refer to the Reference Guide.”
Quick Start Guide 7
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Lesson 1 - Understanding the user interface

Introduction

In this lesson you will learn about the basic parts of the WYSIWYG user interface. 

Step 1 - Starting to work in WYSIWYG

To start working in WYSIWYG

1 From the WYSIWYG Welcome window, choose a file to open. You can choose to 
open an existing file or create a new file. A list of template files are shown on the 
left and a list of files you have recently used are shown on the right. 
Quick Start Guide 9
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2 For the purposes of this tutorial, click Empty. 

Result: The WYSIWYG main window is displayed. 

Step 2 - Mode buttons

The buttons across the top are the mode buttons. Based on the WYSIWYG product that 
you have purchased, the mode buttons available are some or all of the following: 

CAD - This is where you will do all of your drawing.

Data - This is where all of your show information is tabulated on a spreadsheet.

Design - This mode allows you to turn lights on, compose static lighting looks, and 
generate renderings. 

Presentation - This is where you create printouts of your show document including 
reports, plots, and images. 

Live - This is where you pre-cue and visualize your lighting show. 

Step 3 - Menu bar, toolbars, layout tabs

Below the mode buttons is the menu bar. The available menus change as needed when 
moving from mode to mode. 

Below the menu bar are the toolbars. Toolbars provide button access to most 
commands and can be used in lieu of the menu bar. 

Located at the bottom of the screen are layout tabs. Each mode has designated layouts. 
A layout is the configuration of views in your workspace. 

Mode buttons

Layout tabs

Shortcut bar

Toolbars

Menu bar
10
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Step 4 - Shortcut bar

The shortcut bar is located on the left side of your screen. You can create shortcuts for 
library items, ease of navigation, and special tools. For example, you can save a 
navigation shortcut to Live mode/Quad layout so that the next time you want to go 
back to that location, you can simply click the shortcut. 

To create this shortcut

1 Select the navigation shortcut bar, right-click, and then select New Navigation. 

2 Type a name for the shortcut and click OK.
Quick Start Guide 11



Lesson 1 - Understanding the user interface  Release 24
12



July 2009 Lesson 2 - Creating a set
Lesson 2 - Creating a set

Introduction

In this lesson you will learn how to:

insert a venue

build your set using the following methods:
from CAD objects
from library items
using CAD tools

Step 1 - Inserting a venue

Begin in CAD mode. This is the mode in which you create your show drawings. In this 
example, you add a proscenium arch theatre.

To insert a venue

1 From the Draw menu, choose Venue > Proscenium Arch.
Quick Start Guide 13



Lesson 2 - Creating a set  Release 24
2 Accept the default values, and then click OK. 

Result: Your plan view now contains a plan drawing of a proscenium arch theatre. 

Step 2 - Building your set from CAD objects

A number of CAD objects are available from the Draw menu. You can create a set from 
basic CAD objects such as circles, spheres, cylinders, and risers. In this example, you 
will insert a riser.

To build your set from CAD objects

1 From the Draw menu, choose Riser. 

2 In the applicable boxes, specify the dimensions of the riser, for example, 8'x8'x2'.

3 Click OK. 

4 Click to drop the riser in your drawing.

Step 3 - Building your set from library items

Use the pre-drawn items in the WYSIWYG library to insert objects in the drawing. In 
this example, you insert a motorcycle.
14
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To build your set from library items

1 From the Library menu, choose Browse Library. 

2 Select the library item tool  at the bottom of the library browser to ensure that 
you are browsing the scenic library. 

3 Navigate to the desired item, and then double-click to insert. 

Tip: You can save time by using the Library Search feature. In the Library browser, 
simply click the category tab that you are interested in, and then type the object 
name (or part of it) in the Search box at the top of the browser panel. All objects 
that match your query are shown.

4 Move the mouse to a point on stage. Before dropping the object in the drawing, 
press TAB to display the Enter the missing coordinate dialog box. 

The missing coordinate (X,Y,Z) is the coordinate whose value cannot be entered by 
clicking on the screen. 

5 Enter the value for the missing CAD coordinate, for example, 2' (the height of the 
riser), and then click OK.

Tip: As you move your cursor the coordinates are displayed in the bottom right 
corner of the screen. 

6 Click to place the object on top of the riser.

Step 4 - Building your set using CAD tools

WYSIWYG is equipped with powerful CAD tools allowing you to draw anything from 
scratch. In this example, you will draw a basic cyc to illustrate some of these tools.
Quick Start Guide 15
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To draw objects using the CAD tools

1 From the Draw toolbar, select the item that you want to draw, for example a line. 

2 To pick the first point of line, type the coordinates (for example, -20,20,0), and 
then press ENTER. 

Note: When you start typing, the ComEdit toolbar is activated at the bottom of the 
window. 

3 Specify the coordinates for the end point of the line (for example, 20,20,0), and 
then press ENTER. 

4 Right-click and select Finish Line.

To extrude a line into a surface

1 With the line still selected, from the Tools menu, click Extrude, and then choose 
Lines into surfaces. 

2 Enter the value for the extrusion distance, for example 20, and then click OK.

Result: The line is stretched into a surface.

Switch to Shaded view to view your final set design. Your set should look similar to the 
following:
16
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Lesson 3 - Defining hanging positions

Introduction

Once the set is in place, you can define your hang structures. All fixtures in WYSIWYG 
must be placed on a hang structure, which can be either a pipe or truss.

In this lesson you will learn how to insert a hang structure and define the position 
names in your document.

Step 1 - Defining a position name

Position names are used to identify hang structures. To organize and sort the position 
names, use the Position Manager available in WYSIWYG. The order in which the position 
names appear in the Position Manager defines how they are sorted in reports. 

To define a new position name 

1 From the Edit menu, choose Positions. 

2 Click New, and then enter the name of the position.

3 Repeat step 2 for all position names as desired. 

4 To sort the position names, use the Up and Down buttons to move the selected 
name in the list. 

Step 2 - Drawing a pipe

Pipe hang structures can be drawn using the Draw menu.

To draw a pipe

1 From the Draw menu, choose Pipe.

2 Choose the associated position name as defined in “To define a new position name” 
on page 17.
Quick Start Guide 17
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3 Specify the dimensions for the pipe (for this example, accept the defaults), and 
then click OK. 

4 Click or type to place the pipe in your drawing. 

Step 3 - Inserting truss

Truss hang structures can be inserted from the library. 

To insert truss

1 Activate the Assembly snap tool  to ensure truss pieces are bolted together.

2 From the Library menu, choose Browse Library.
3 Click the truss tool  at the bottom of the Library browser to ensure that you are 

browsing the truss library 

4 Navigate to the desired piece, and then double-click in your drawing to insert it. 

5 Hover your cursor over your drawing where you want to insert the object. Press 
TAB to set the missing coordinate before clicking to place the piece of truss in your 
drawing.

6 Click to place the first piece of truss.

7 To assemble subsequent pieces, hover the cursor over the end of the piece of truss 
you want to attach it to and it will automatically snap into position.

Tip: It may be useful to zoom in as needed.

8 Once the piece has snapped into position, click to insert it into the drawing.

9 When you are finished placing truss, right click and select Finish Placing Truss.

To assign a position name 

1 Double-click the truss structure to open its properties. 

2 On the Hang Structure tab, from the Name drop-down box, select the desired name. 

3 Click OK.
18
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Lesson 4 - Hanging and focusing fixtures

Introduction

After inserting hang structures into your drawing, you are now ready to hang and focus 
fixtures. A library of fixtures is available for you to choose from. 

In this lesson you will learn how to:

hang fixtures

focus fixtures

Step 1 - Hanging fixtures

Fixtures are objects on the plot and must be hung from a hang structure. 

To hang fixtures

1 From the Library menu, choose Browse Library. 

2 Select the fixture tool at the bottom of the library browser to ensure that you are 
browsing the fixture library. 

3 Navigate to the desired item, right-click, and then select Insert. 
4 Move the mouse over a hanging structure (pipe or truss) and click to hang the 

fixture. 

5 When you have finished placing the fixtures, right click and select Finish Placing 
Fixtures. 

6 Repeat steps 3-5 for all desired fixture types. 

Step 2 - Inserting a focus position

There are three methods for focusing fixtures: 

clicking and dragging the light beam of the selected fixture 

changing the pan and tilt values by double-clicking to access the fixture’s 
properties box

inserting focus positions

The method for inserting focus positions is described here. 

Focus positions allow you to quickly attach a focus value to a fixture. 

To insert a focus position

1 From the Draw menu, choose Focus Position. 

2 Type a label for the new focus position and then click OK. 

3 Press TAB to adjust the missing coordinate, if necessary. 

4 Click to place the focus position in the drawing. 
Quick Start Guide 19
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Step 3 - Focusing fixtures using focus positions

To associate a fixture with a focus position

1 From the Tools menu, choose Quick Focus.

2 Click on the focus position to set it as the active focus position, and then click on 
the desired fixture to set its focus position. 

3 When you are finished focusing fixtures, right-click and select Finish Quick Focus.
20
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Lesson 5 - Assigning fixture attributes

Introduction

In this lesson you will learn how to assign attributes to fixtures. 

Step 1 - Assigning attributes to fixtures

Once you have fixtures in your drawing, you may want to assign data, accessories, or 
other attributes to them. To quickly assign values to fixtures, use Quick Tools, which is 
available in CAD mode. 

To use Quick Tools

1 From the Tools menu, choose Quick Tools.

2 Select the tool(s) that you want to activate, and enter the initial value. When you 
have completed your selections, click OK.

Result: The cursor will show a “Q” to indicate that Quick Tools has been activated.

3 Click on the fixtures one by one to assign the specified information.

Tip: The prompt line at the bottom left corner displays the parameter information 
that will be assigned to the next fixture that is clicked on. 

4 When you are finished using Quick Tools, right-click and select Finish Quick Tools.
Quick Start Guide 21
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Step 2 - Filtering and modifying data

Any attribute associated with a fixture in your WYSIWYG drawing (for example, 
purposes, control channels, focus positions) is available for you to edit in Data mode. 
Any changes that you make are reflected throughout the entire file, including the 
drawing.

Begin in the spreadsheet. You can use data filters to quickly locate data in the 
spreadsheet.   

To use a data filter

1 Right-click on the parameter heading for which you want to specify a filter (for 
example, the Type parameter). 

2 Select Add Data Filter.

3 Select the value that you want to filter (for example, 6” Fresnel), and then click OK. 

Result: The spreadsheet refreshes, displaying only the fixtures that meet the filter 
criteria.

4 Make any data changes that you require. To add or modify information, enter the 
data in the appropriate cell. You can add or modify chunks of information at the 
same time by selecting a series of cells and typing. 

5 To remove the filter, right-click in the appropriate column, and then select Remove 
Data Filter.

Step 3 - Entering sequential numerical data

To enter sequential numerical data

1 Enter the first number in the appropriate cell.

2 Press and hold the ALT key, and then press the down arrow to input subsequent 
values incrementally. 

Step 4 - Choosing data

To choose data

1 If you are unsure of the exact value for parameters such as colour, gobo, and 
other parameters that make reference to library items, right-click the item, and 
then select Pick value from the list. 

Result: This action opens a dialog with a pull-down list of the values currently 
used in your file.
22
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2 Choose the value that you want, or click Library to make a new selection. 

Note: This is only available for certain fields (for example, the Type column and 
Lens column). 
Quick Start Guide 23
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Lesson 6 - Building lighting looks in Design mode

Introduction

In Design mode, you can create static lighting looks using the design tools. You can 
then save and render these looks to output photorealistic images. Note that you can 
only control fixture parameters that are ordinarily controlled by DMX.

You can also simulate cross-fading between lighting looks without the need of a lighting 
console by using the shortcut properties in the shortcut bar to specify the fade time in 
seconds. This is the amount of time that it takes to “fade” to this look when you click on 
it from another look in the shortcut bar. 

Once you create the look and specify the fade time, you can use the design tools to 
customize the look. When you switch from one look to the next, you can see the 
movement of the lights from one position to the next, along with any changes you have 
made between looks, such as color, intensity, and so on. 

In this lesson you will learn how to build a lighting look in Design mode and cross-fade 
to another lighting look. 

Step 1 - Creating a new lighting look 

To create a new look

1 In the Looks shortcut bar area, right-click and select New Look. 

2 Type the name of the new look (for example, Scene1).

3 In the Fade time box, type the fade time in seconds for this look, and then click OK. 

4 Create another look in the same way, this time with a different look name. 
Customize both looks in the following steps.

Step 2 - Using the Intensity tool

The zoom, intensity, and iris tools all work the same way. 

To use the zoom, intensity, and iris tools

1 In your drawing, select the desired fixtures.

2 Open the Intensity tool, for example, by clicking the appropriate tool on the 
designer toolbar . 

3 Click the dial, and then move the mouse up or down to set the intensity level, or 
click Full to set the intensity to 100%.
Quick Start Guide 25
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Step 3 - Using the Gobo tool

The gobo and prism toolbars work the same way. 

To use the gobo and prism tools

1 Open the Gobo tool, for example, by clicking the appropriate tool on the designer 
toolbar .  

2 To assign a gobo, with the desired fixtures selected, select the desired wheel from 
the drop-down list, and then use gobo selection arrows to choose the desired gobo. 

Step 4 - Using the Focus tool

To use the focus tool

1 Open the Focus tool by clicking the appropriate tool on the designer toolbar . 

2 To focus automated fixtures, with the fixtures selected, choose from any of the 
following three methods:

Use the focus trackpad by clicking on the pad, and then moving the mouse.
Click the Focus button, and then click in the Wireframe drawing.
Choose a focus position from the drop-down list. 
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Step 5 - Using the Color tool

To use the color tool

1 Open the Color tool by clicking the appropriate tool on the designer toolbar . 

2 To assign color, with the desired fixtures selected, click to pick a color on the 
palette or the color wheel.

3 If desired, you can use the RGB drop-down boxes to manually enter RGB, CMY, or 
HSI values.

Step 6 - Opening the Render Wizard

The Render Wizard steps you through the process of generating a rendering of your 
drawing.

To open the Render Wizard

1 With the desired lighting look active, open the Render Wizard by clicking on the 
appropriate tool on the designer toolbar . 

2 In the right pane, click and drag the mouse to set up your image.

3 In the left pane proceed through the Wizard steps by using the Next and Back 
buttons. 

For more information on the options available for rendering, consult the WYSIWYG 
Reference Guide. 

Step 7- Cross-fading between lighting looks

After setting up at least two lighting looks, you can “fade” between them by using the 
cross-fade feature.

1 Ensure that the Fade looks button is enabled so the look fades instead of jumping 
directly to the next look. 

Tip: If the button is not enabled, then you can “jump” from one look to the next by 
clicking the look shortcuts in the shortcut bar. Even if the button is enabled, you 
can always jump to the next look by right-clicking the look shortcut, and selecting 
Jump to.
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2 To watch the “fade” from the first look to the second look, click the shortcut for the 
second look. The image fades over the period of time that you specified as the fade 
time for the second look. 

Tips: 

For a more realistic view of the fading between looks, click the Shaded tab.

To jump directly to a specific look, right-click the look, and then select Jump to.
28



July 2009 Lesson 7 - Creating and modifying reports
Lesson 7 - Creating and modifying reports

Introduction

In Presentation (Pres) mode, a series of pre-formatted reports is available for you to 
use as is or to modify to suit your needs. Unlike the spreadsheets in Data mode, you 
cannot edit fixture data in these reports. You can, however, modify the setup and 
layout of these reports. 

In this lesson you will learn how to work with reports. 

Step 1 - Entering show information

Shortcuts to the pre-formatted reports in Presentation mode are available in the 
shortcut bar. Click the desired report shortcut to open it. Show information such as 
venue, designer, show, and assistant is displayed at the top of each report. 

To add or modify show info

1 From the Options menu, choose Show Options.

2 Click the Show Info tab.

3 Make the necessary changes or additions (for example, add John Smith as the 
lighting designer).

4 Click OK. 
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Step 2 - Modifying a report

To modify a report

1 In the shortcut bar in Presentation mode, click a shortcut to open a report.

2 Right-click in the open report, and then choose View Options. 

Result: The View Options dialog opens with the General and Report tabs available. 

3 Click the Report tab. 

Group By

The Group By drop-down list enables you to select a data field for grouping the 
data. These groups appear as separate tabs at the bottom of a report. Choose None 
to have all information displayed on the same page.

Columns

The Columns list displays the columns available for inclusion or exclusion in a 
report. You can display the fields in any order by arranging the order of this list 
using the Up and Down buttons. The top of the column list represents the left 
column on the page and the bottom of the list is the right column. To move a 
column up or down the list, click the column name and then use the Up/Down 
buttons. 

Sort By

The Sort By list contains the settings for how the report is sorted. The keys that you 
specify are sorted in alphabetical or numerical order. When fixtures have the same 
value in the first sort key, the report is then sorted by the second sort key, and so 
on for the third sort key. 

When you have set all the options, click OK to save and exit. The report refreshes 
and any changes are reflected immediately.
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Step 3 - Formatting report headings

To format the report headings 

1 Right-click in the report, and then choose Redesign headings.

2 Select the text to be formatted.

3 From the Format menu, choose alignment, font, border and color controls to 
customize the heading text. For example, change the font and color for the title 
“Instrument Count”. 

4 From the File menu, choose Save.

5 Close the Redesign Headings dialog box.

Result: A message box ask if you want to apply the heading to all reports in the 
document.

6 Click Yes to indicate that all reports will be modified. Click No to change only the 
chosen report.

7 Adjust column widths by clicking and dragging the column borders. 

8 From the File menu, choose Save.
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Lesson 8 - Working in the New Plots view

Introduction

New Plots views were introduced so that you could more effectively manipulate a 
drawing developed in CAD mode to create a lighting plot, or “schematic”, for printing. 

Note: You cannot change the properties of items that you have inserted in CAD mode; 
you can only change the properties of items that you have inserted in the New Plots 
view.

In this lesson you will learn how to work with New Plots. 

Step 1 - Creating a New Plot

To create a New Plot

1 In Presentation mode, click the New Plots shortcut tab.

2 Right-click in the New Plots shortcut area, and then choose the type of plot that you 
want to create.

3 Type a name, and then click OK.

Note: By default, empty layouts are set up to use 24” x 36” sheets of paper. 

To modify the paper size

1 In your New Plot, right-click in the report area, and then choose View Options. 

2 From the Paper Size drop-down list, select the desired paper size. 

3 Click OK to save and exit.

Next, you can determine the parts of the drawing that you want to see on the page by 
moving the page. 
Quick Start Guide 33



Lesson 8 - Working in the New Plots view  Release 24
To move the page

1 Right-click in the New Plots work area, and then choose Move Page. 

Result: The cursor turns into a hand symbol.

2 Hold down the left mouse button to grip the page and drag to move it until the 
parts of the drawing that you want are contained within the grid area. 

3 When you are finished, right-click and choose Finish Move Page. 

Step 2 - Manipulating objects on the plot

A New Plot is a snapshot projection of your CAD drawing. Once the snapshot is taken, 
you can modify objects on the New Plot without affecting the original CAD drawing.

Tip: Zoom in by pressing PAGE UP or by using the middle mouse button to facilitate the 
set-up. 

To manipulate the objects on a plot

1 In the New Plot, select an object.

2 Click and drag to modify its position; to modify the layer properties, right-click the 
object, and then choose Object Properties. 

3 Modify the properties as required.

4 Click OK.

Step 3 - Plotting non-horizontal hang structures

In the New Plots view, you can rotate non-horizontal hang structures, such as booms 
and ladders, around their base to show all mounted fixtures. This rotation can be right, 
left, top, or bottom. 

To plot non-horizontal hang structures

1 Select the hang structure.

2 Right-click and select Rotate Position.

3 Select the direction and angle in which you want to rotate the hang structure.

4 Click OK. 

Step 4 - Inserting objects

You can add objects to the plot for notation by simply drawing or selecting them from 
the Draw menu. Objects that you can draw include lines, arcs, circles, and text labels. 
You can also insert symbols from the Library Browser.
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To insert objects

1 From the Draw menu, choose the object that you want to insert. 

Note: Choosing Symbol opens the Library Browser. 

2 In the properties box that opens, type the properties of your object.

Note: If you choose Interactive, you can change the size of the object manually.

3 Click OK, and then click in the plot to place the object.

Tip: You can resize objects by clicking and dragging them.

To add arrows to lines

1 Select the line to which you want to add one or more arrows.

2 Right-click and select Object Properties.

3 Click the Line tab. 

4 Select where you want the arrows to appear, either at the start or end of the line, 
or both places.

5 Click OK.

To change a single line to a double line

1 Select the line that you want to modify.

2 Right-click it, and then select Object Properties.

3 Click the Line tab. 

4 Select the Double Line check box.

5 Click OK.
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Lesson 9 - Creating and modifying layouts

Introduction

In WYSIWYG, layouts are created by arranging various CAD, report, image, and other 
items on a defined paper size. 

In this lesson you will learn how to work with layouts. 

Step 1 - Creating a new layout

To create a new layout

1 In Presentation mode, click the Layouts shortcut tab.

2 Right-click in the Layouts shortcut area, and then choose New Layout.
3 Type a name, and then click OK.

Note: By default, empty layouts are set up to use 8.5” x 11” sheets of paper. 

To modify the paper size

1 Right-click in the layout area and choose View Options. 

2 From the Paper Size drop-down list, select the desired paper size. 

3 Click OK to save your changes and exit.

You may now begin placing objects on the sheet of paper. Use the Pres Insert toolbar to 
facilitate the process.

Tip: Zoom in by pressing PAGE UP to facilitate the setup. 
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Step 2 - Inserting objects into the layout

To insert objects on the layout

1 To insert and object, select the appropriate icon from the Pres Insert toolbar.

2 Click and drag a window (placeholder) on the layout where you want the item to 
appear.

3 Repeat this procedure for all desired items. 

Step 3 - Modifying CAD items

To modify CAD items

In this example you will modify the scale of a drawing item. 

1 Select the CAD item, right-click, and then choose Content Properties. 

2 Click the CAD Printing tab.

3 Click the Fixed option button.

4 From the drop-down list, select Custom.

5 Type the scaling to be used when printing the drawing, for example, fixed at 
1/8”=1’. 
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6 Select any other desired items, and then click OK.

Step 4 - Adding legends and keys

The Legend and Key Wizards guide you through the process of adding a legend or key 
to your layout. 

Legends  You may want to add a legend to your layout to provide a definition of 
the symbols used in the layout. The legend you create can include the symbol 
name, wattage, count, and any other special notes. 

Keys  You may want to add a key to your layout to provide a definition for the 
fixture notation used in the layout. The key you create can include the symbol of 
one given fixture and identifiers for the various attributes notated around the 
symbol. 

To open the Wizards

1 In the shortcut pane, click Wizards.

2 Right-click in the Wizards shortcut bar, and then select the appropriate item. 

3 Type a new name for your legend or key, and then click OK.

4 Proceed through the steps using the Next and Back buttons. 

To place the legend or key

1 On the Insert toolbar, either the Legend or Key icon.

2 Click and drag a window placeholder on the layout where you want the legend or 
key to appear.

Result: A message box prompts you to select the legend or key from the list. 

3 Highlight the legend or key, and then click Select.
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Lesson 10 - Patching

Introduction

In WYSIWYG, you can create two types of patch universes:

DMX  When you create this type of patch universe, you can patch fixtures or 
movement axes to it by assigning them a DMX address. The patch screen in Data 
mode is a visual representation of your DMX patch setup and is also used to 
monitor DMX activity while connected to a console.

Motion Control  When you create this type of patch universe, you can patch 
movement axes to it, and then use a motion control system (or WYSIWYG’s Motion 
Control Console) to control the movement of any objects that are attached to the 
axis.

In this lesson you will learn how to patch fixtures and read a resulting patch universe.

Step 1 - Creating a new patch universe

To create a new patch universe

1 In Data mode, click the Patch tab.

2 Click the Patch shortcut bar. 

Result: The Patch shortcuts are displayed.

3 Right-click in the shortcut bar, and then select New Patch. 

4 Type the name of the patch universe. Patch universes can be named anything. For 
example, “A”, “Dimmers”, “Dim”, “Movers”, “Scrollers”, and so on.

5 Select the type of patch universe based on the type of console or system that you 
are using, either a DMX console, or a motion control system.

6 Click OK.

Result: The patch shortcut appears in the Patch tab.

Step 2 - Patching fixtures and movement axes in the patch layout 
screen

To patch fixtures and movement axes in the patch layout screen

1 In the CAD drawing in the top portion of the window, click to select the desired 
fixture or movement axis.

2 Click and drag the fixture/movement axis into the DMX or motion control patch 
universe at the bottom of the window.

3 Repeat for all fixtures/movement axes as desired. 
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Step 3 - Repatching a fixture

To repatch a fixture

Select the desired fixture by clicking its first DMX attribute directly in the patch 
universe, and then drag it to a new address.

Step 4 - Reading the patch

Reading the DMX patch

The name of the patch universe is displayed in the title bar. 

Each box in the patch universe represents one DMX channel. Fixtures are represented 
by colored bumps that span the number of required DMX channels. 

If you are connected to a console and are receiving a DMX signal, the incoming DMX 
values are displayed in the top right corner of each box. 

The number in the upper left corner of each box is the DMX address. 

The fixture parameter controlled by each channel is identified in the center of the box. 

The spot number and fixture type span the center of the box. 

Reading the patch for streaming video sources
If you have patched a live video source or file, the patch appears as shown below:
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Reading the patch for moving scenery
If you have patched a movement axis, the patch appears as shown below:

For linear movement axes, the position of the object is reported in either metric or 
imperial units (for example, 16m). 

For rotational axes, the value is shown in degrees (for example, 42°).

If the axis is unrecognized by the motion controller, then the object position is 
shown as a question mark (?).

Note: If the axis type is mismatched between that which you have drawn and the type 
that you choose in the Motion Control Console (for example, if the actual axis is linear, 
but you choose rotational in the Motion Control Console), then the cell in patch view 
turns to red.
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Lesson 11 - Inserting and connecting to a console

Introduction

WYSIWYG enables you to visualize and pre-cue your lighting show in real time. To use 
Live mode, you must be connected to a DMX console, compatible off-line editor, or a 
motion control system.

Note: Ensure that your hardware and/or software is properly set up.

In this lesson you will learn how to insert a console and connect that console in Live 
mode. 

Step 1 - Inserting a console

To insert a console

1 From the Live menu, choose Device Manager.

2 Click New.

3 Expand the Manufacturer section, and then choose the desired console (for 
example, Express 24/48). 

4 Click Insert. 

Step 2 - Connecting to a console

To bind the console output to the patch universe

1 In the Device Manager window, highlight the console, and then click Properties. 

2 From the Protocol drop-down list, select the protocol used by the console. For 
example, DMX, SandNet. 

Result: The console model is displayed in the Model box. The name of the console 
is displayed in the Name box. 

3 In the Address box, type the designated address of the console, if applicable.
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4 A list of the output ports from the console appears in the Ports list. You must bind 
these outputs to WYSIWYG patch universes. Click the appropriate port to highlight 
it.

Note: Motion control systems have a single port named “Motion.”

5 Click Bind.

Note: If you are working with a motion control system, then you can bind only to 
motion universes; if you are working with a DMX console then you can bind only to 
DMX universes.

Result: The Patch Universe Select dialog box is displayed.

6 Select the desired Patch Universe, and then click Select.

7 Repeat the above steps to bind all ports to their appropriate patch universes. 

Note: You cannot control a channel count exceeding that of the WYSIWYG Perform 
package that you purchased - 500, 1000, 2000, 5000, and so on.

8 Click OK to close the Properties box.

9 Click Connect. 

Result: The status of the console changes to “connected.”

10 Click OK to exit the Device Manager.

Note: Once the console is running and connected to the WYSIWYG drawing, 
operate the console as you would in the live venue. Run up channels and record 
cues using the console. Remember that WYSIWYG does not store or save cues—
this is done in your console’s memory. Once the console information is set up, you 
can set WYSIWYG to automatically connect to the console every time the file is 
opened.
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Lesson 12 - Using streaming video

Introduction

Streaming video enables you to bring a live or pre-recorded video stream into 
WYSIWYG and play it back while you set looks in Design mode and while you precue in 
Live mode. 

In this lesson you will learn how to

configure a new video source with the Video Manager

draw the screen on which the video will play and assign the video source to it

use the Video design tool to play the video

use a console to play the video

Step 1 - Configuring a new video source

To configure a new video source for streaming video

In this step you create a new video source for streaming video with the Video Manager. 
You can select a video file or you can capture a live video stream from an external 
source, such as a video capture device that is attached to your computer (provided that 
you have WYSIWYG Perform). 

For video files, you must select one of the following video file formats for playback:

Motion Picture Experts Group (MPEG)

Audio-Video Interleaved (AVI) 

Note: If you cannot view these file types, you may not have the proper decoder 
installed on your PC. Install the appropriate decoder, and then try viewing the file 
again. For help on installing the decoder, consult the developer of the video file type.

For live video streams, your capture device must be using WDM drivers.

Note: You can only incorporate live video if you have WYSIWYG Perform; you cannot 
select a video from a live capture device if you have WYSIWYG Design.

1 Click Tools > Video Manager. 

2 Click New.

Result: The Video Source window opens.

3 In the Name box, type a descriptive name for the video.

To play a video from a file, click the Video File option button, and then click 
Browse to locate the file.

To capture a live video stream from an external source, such as a web cam or 
a video capture device that is installed on your computer, click Video Capture, 
and then use the drop-down arrow to select the appropriate device. (This 
option is available only if you have WYSIWYG Perform installed.)

Note: The video capture device must already be configured on your computer and 
must be using WDM drivers.
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4 To play the video with a DMX control, click DMX Patch, and then use the drop-down 
arrow to select the appropriate patch universe to control the video. In the box to 
the right of the drop-down list, type the starting DMX address. 

Note: You must have a named patch already configured on your computer.

5 Click OK.

6 In the Video Manager, ensure that the status of the video source is Connected. If it 
is not, then press Connect.

7 Click OK to save your changes and close the Video Manager.

Step 2 - Drawing a screen and attaching the video source

To draw a screen and attach the video source

1 From the Draw menu, click Screen.

2 In the appropriate boxes, type the width and height of the screen (or accept the 
default width of 8 feet and height of 6 feet).

3 To configure the image that will appear on the screen, click the appropriate option 
button:

To leave the screen blank, click the Blank Screen option button.

To show a static image on the screen, click the Image File option button, and 
then click Browse to locate the graphic. 

To attach the video source that you have just configured to the screen, click 
the Video Source option button, and then choose the video source from the 
drop-down box.

4 Click OK.

Step 3 - Using the Video design tool to play the video

After you draw the screen and attach the video source, you use the Video Designer Tool 
in Design mode to start the playback or stream. You can view the video in any of the 
shaded views, using the controls on the Video designer tool to pause, fast forward, 
rewind, or stop the video. 

To use the Video design tool to play the video

Once you have the video source attached to the screen, you must use the Video design 
tool to control it.

Note: If the video control is patched and DMX connected in Live Mode, then you will not 
be able to control the video using any of the Video design tool commands in Design 
mode. Video sources can only be controlled by a designer tool when the DMX source is 
disconnected; therefore, you must first disconnect the applicable console device from 
within Live Mode before using any of the Video design tool commands. 
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1 Click the Design mode button.

2 Click the Shaded tab to view the video screen(s) that you have drawn.

3 Click the Video design tool icon to open the tool window. 

4 From the drop-down list, select the video source. 

5 Use the controls shown in the graphic above to play, pause, or stop the video. You 
can also use the slider to manually advance or rewind the video at your desired 
speed. 

Note: When you press the Pause button, the frame of the video that is playing at 
the time is held on the video screen; when you press the Stop button, the video 
stops playing and the screen goes blank and the video returns to the beginning. 

Step 4 - Controlling the video with a console device

You can also patch the control of the video source to a console device. This means that 
you can use the console device to control the progress of a live video stream or a video 
file by making the video play, pause, or rewind; you cannot use WYSIWYG to change 
different aspects of the video itself. 

Note: To control the video source with a console device, you must have selected DMX 
Patch in the Video Source window in Step 1, and then chosen the patch universe for the 
video source. Also, your console device must be connected.

To control a DMX patched video source with a console

After you have patched the control of a video source in Data mode, you can use the 
applicable console device to control the progress of the video in Live mode. 

To control the video source, the DMX patch is allocated three channels, each given a 
different name in the patch window: 

The first channel is called Intensity.

The second channel is called Control.

The third channel is called Position. 

For details on the channel levels, see the Reference Guide. 

1 Click the Live mode button.

2 Click the Shaded tab.

3 Ensure that the console device is connected to the patched video source. 

To play the video from start to finish, perform the following steps:

a. Set the first channel (Intensity) to a value between 128—255 (above 50%).

b. Set the second channel (Control) to a value between 170—255 (between 66% 
and 100%).

To pause the video, perform the following steps:

a. Set the first channel (Intensity) to a value between 128—255 (above 50%).

b. Set the second channel (Control) to a value between 170—255 (between 66% 
and 100%) and play the video to the spot where you want to pause it. Then 
move the second channel to a value between 85—169 (between 33% and 
66%) to pause the video at this spot.

To control the progress of the video manually, perform the following steps:

a. Set the first channel (Intensity) to a value between 128—255 (above 50%).
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b. Set the second channel (Control) to a value between 1—84 (between 1% and 
33%).

c. Slide the third channel (Position) up and down to control the progress of the 
video, forward and backward. 

Notes: 

Before you render your drawing, you can either pause the video at the precise 
image you want to see in the final rendering, or you can let the video run while the 
Render Wizard processes the information in your drawing. In this case, the Render 
Wizard captures the video frame that was showing when it processed the screen 
information. 

If the video control is patched and DMX connected in Live Mode, then you will not 
be able to control the video using any of the Video Designer Tool commands in 
Design mode. Video sources can only be controlled by a designer tool when the 
DMX source is disconnected; therefore, you must first disconnect the applicable 
console device from Live Mode before using any of the Video Designer Tool 
commands. 
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Lesson 13 - Using moving scenery

Introduction

You can view moving scenery in WYSIWYG by creating linear or rotation movement 
axes, attaching objects to them, patching them in Data mode, and then using a motion 
control system (or WYSIWYG’s Motion Control Console) to define the object’s position 
along the axis. You can attach objects such as risers, library objects, or custom objects 
that you have drawn. 

Notes: 

When attaching axes to one another, you cannot create a circular linking pattern. 
For example, you can link Axis A to Axis B, and then link Axis B to Axis C, but you 
cannot then link Axis C back to Axis A because this creates a circular link.

You cannot attach fixtures to movement axes; however, you can attach pipes that 
hold fixtures to axes. 

Currently, you cannot attach focus positions or groups containing focus positions to 
movement axes. However, in future releases you will be able to attach either of 
these items to movement axes.

Step 1 - Drawing the movement axis

To draw a linear movement axis

1 In CAD mode Wireframe view, select the view in which you want to draw the axis 
(plan, front, back, side, or isometric)

2 Click Draw > Axis > Linear Axis.

3 In the window that appears, type a name for the axis, and then click OK.

4 In your drawing, click in the position where you want to start the axis, and then 
move your cursor to the next point of the axis and click. To create an axis with 
multiple segments, continue clicking at each point (vertex) of the axis. 

5 When you are finished creating the axis, right-click and choose Finish Axis.

To draw a rotation movement axis

Note: Unlike linear axes, rotation axes cannot have multiple vertices. Instead, when 
you draw one of these axes, the object rotates around the center point.

1 In CAD mode Wireframe view, select the view in which you want to draw the axis 
(plan, front, back, side, or isometric).

2 Click Draw > Axis > Rotation Axis.

3 In the window that appears, type a name for the axis, and then click OK.

4 In your drawing, click in the position where you want the axis to appear.

Note: The circle that appears when you draw a rotation axis is only a visual cue to 
show you the direction in which the object rotates—it does not affect the size of 
path on which the object rotates. The circle is given a default size, but you can 
change it to suit your needs.
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Step 2 - Attaching a movement axis to a patch universe

To attach a movement axis to a DMX patch universe

To move the object with a DMX control, you first have to attach the movement axis to a 
named DMX patch universe that you have created in Data mode.

Note: For information on creating a patch universe, see “Step 1 - Creating a new patch 
universe” on page 41.

1 Click to select the axis that you want to attach to the patch universe.

2 Right-click and select Properties.

3 Click the Axis tab.

4 Click the DMX Patch option button.

5 From the Universe drop-down box, select the DMX patch universe to which you 
want to attach the axis.

6 In the Address box, type the starting DMX address.

7 Click OK.

To attach a movement axis to a motion patch universe

To move the object with a motion control system, you first have to attach the 
movement axis to a named motion control patch universe that you have created in Data 
mode. 

Note: For information on creating a patch universe, see “Step 1 - Creating a new patch 
universe” on page 41.

1 Click to select the axis that you want to attach to the patch universe.

2 Right-click and select Properties.

3 Click the Axis tab.

4 Click the Motion Patch option button.

5 From the Universe drop-down box, select the motion control patch universe to 
which you want to attach the axis.

6 From the ID drop-down list, select the ID on the motion control system with which 
you want to associate this axis. 

Note: The motion control system must be connected to your computer for the ID 
to appear in this drop-down list. If the system is not currently connected, you can 
also type the ID directly into this drop-down list box.

7 Click OK.

Step 3 - Attaching objects to the movement axis

To attach an object to a movement axis

Notes: 

You can attach one or more objects to each axis; however, each object can be 
attached to only one axis at a time. 

When you attach an object to a linear axis, the distance from the axis to the 
object does not affect the object’s movement; the object will always follow the 
path of the axis regardless of where you have placed the axis or object. 
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When placing the object to be rotated in your drawing, note that its position 
relative to the rotational axis is important. The distance from the central point 
of the axis to the object represents the size of the circle in which it will rotate. 
To have the object rotate in a very tight circle (for example, a dancer doing a 
pirouette, or a spinning object), place the object directly on the center point of 
the axis.

1 Place the object that you want to attach to the axis at the appropriate position in 
your drawing, either by adding a new object, or moving an existing object to this 
location.

2 Select the object, right-click, and then choose Properties.

3 On the General tab, from the Attach to Axis drop-down box, select the axis to which 
you want to attach this object.

4 Click OK.

Step 4 - Viewing moving scenery

You have two choices when viewing moving scenery:

You can use the Moving Scenery designer tool and the Cross-Fade feature in 
Design mode to fade between looks containing moving scenery.

You can use a DMX console or a motion control system in Live mode to control the 
movement of objects attached to patched movement axes. 

To view moving scenery in Design mode

1 In Design mode, in the shortcuts bar, click Looks.

2 In the Looks shortcut area, right-click, and then select New Look.

3 In the Name box, type the name of the new look.

4 In the Fade time box, type the fade time in seconds for this look. 

5 Click OK.

6 Scroll to the bottom of the Looks shortcuts list.

7 Click on the shortcut for your new look.

8 Click the Moving Scenery Designer Tool icon ( ).

9 From the drop-down list in the Scenery window, select the appropriate movement 
axis. 

10 Click the slider to advance the object to the position where you want it to start on 
the selected axis. 

Note: In the Start box, you can also type the object’s position as a percentage of 
its full range of movement. For example, to show the object at the exact half-way 
mark on the movement axis, type 50. 

11 To create the next look, in the Looks shortcut area, right-click, and then select New 
Look.

12 In the Name box, type the name of the new look.

13 In the Fade time box, type the fade time in seconds for this look. 

14 Click OK.

15 Scroll to the bottom of the Looks shortcuts list.

16 Click on the shortcut for your new look.

17 From the drop-down list in the Scenery window, select the appropriate movement 
axis. 
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18 Click the slider to advance the object to the position where you want it to start on 
the selected axis. 

19 Ensure that the Fade looks button is enabled so the look fades instead of jumping 
directly to the next look. 

Tip: If the button is not enabled, then you can “jump” from one look to the next by 
clicking the look shortcuts in the shortcut bar. Even if the button is enabled, you 
can always jump to the next look by right-clicking the look shortcut, and selecting 
Jump to.

20 To watch the “fade” from the first look to the second look, click the shortcut for the 
second look. The object moves from the starting point of the first look to the 
starting point of the second look over the period of time that you specified as the 
fade time for the second look. 

Tips: 

For a more realistic view of the fading between looks, click the Shaded tab.

To jump directly to a specific look, right-click the look, and then select Jump to.

For details on controlling the object’s movement with a console device, such as 
the Mini Console, see “To control a DMX patched movement axis with a console 
in Live mode” below or “To control a motion-control patched movement axis 
with a motion control system in Live mode” on page 54.

To control a DMX patched movement axis with a console in Live mode

After you have patched a movement axis in Data mode, you can use the applicable 
console device in Live mode to control the movement of any objects that are attached 
to the axis. 

To control the object, the DMX patch is allocated two channels with the following 
controls:

First channel (Move): The first channel is for coarse movement and can be used 
to advance the object quickly to any position along the entire path, from start to 
finish. 

Second channel (Move Fine): The second channel is used for further refining 
the object’s position that you set with the first channel. Adjust the slider on the 
second channel to move the object very slightly either forward or back from its 
current position. The movement achieved with this channel is so fine, that it is best 
viewed on linear axes that are quite long. Note that for rotation axes, the 
movement is so slight, that you may not be able to see it.

1 Ensure that the console device is connected to the patched movement axis. For 
details on connecting a console, see “Step 2 - Connecting to a console” on page 
45.

2 To move the object quickly along the movement axis, adjust the slider on the first 
channel, stopping at the position where you want to leave the object.

3 To move the object in fine increments either forward or back from its current 
position, adjust the slider on the second channel.

Tip: To view fine movement, the object must be attached to a very long linear 
axis, or be set to rotate in a very wide arc. It is also a good idea to zoom in quite 
close to the object before moving it.

To control a motion-control patched movement axis with a motion 
control system in Live mode

After you have patched a movement axis in Data mode, you can use the applicable 
motion control system in Live mode to control the movement of any objects that are 
attached to the axis.
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Based on the type of system that you are using, you can control the object in different 
ways. The following procedure outlines how to control the object(s) with WYSIWYG’s 
Motion Control Console.

1 Launch the Motion Control Console.

2 Ensure that the Motion Control Console (or the motion control system if you are 
using one) is connected to the patched movement axis. You connect the Motion 
Control Console (and motion control systems) in much the same way as you 
connect consoles. For details, see “Step 2 - Connecting to a console” on page 45.

3 To change the settings of a patched movement axis, highlight the axis in the left 
pane, and then choose from the following settings:

ID box: To change the ID of the movement axis, type the new motion control 
ID. 

Travel box: Type the distance (in meters for linear axes, in degrees for 
rotational axes) that you want the object to travel along or around the axis. 
This can be the full length/angle of the axis, or only a portion of it if you do not 
want the object to travel along/around the full path. For linear axes, if you 
type a value that is longer than the actual axis, the object stops at the end of 
the physical axis.

Type: If you change the axis type so that it does not match the axis that you 
have drawn (for example, if the actual axis is linear, but you choose rotational 
here), the cell in patch view turns to red. 

In the Mode area, select the type of movement for the object:

Static  Select this option if you want to specify the precise location of a 
static object on the movement axis. You can then use the position slider at 
the bottom of the window to adjust the position and control the movement 
of the object manually.

Bounce  Select this option if you want the object to move forward and 
backward in a continuous loop along the movement axis.

Forward  Select this option if you want the object to move forward along 
the axis from start to finish, and then start over again at the beginning in 
a continuous forward loop.

Backward  Select this option if you want the object to move backwards 
along the axis from finish to start, and then begin over again in a 
continuous backwards loop.

Duration box: If you have chosen any moving Mode value (that is, any value 
except Static), you can specify the length of time (in seconds) over which you 
want the full range of motion to take place. The larger the number you type in 
this box, the slower the object moves.

Position slider: For all moving modes (bounce, forward, backward), the 
slider indicates the position of the object when the console is sending data to 
WYSIWYG. For the static mode, while the console is started, drag the slider to 
to adjust the position of the object on its axis. The position value changes in 
the box in the left pane.

Position box: While the console is sending data to WYSIWYG, for all moving 
modes, this box shows the progress of the object’s movement along its axis; 
for the axes in the static mode, you can type the precise location of the object 
on the axis.

4 Click Update Axis to view your new settings.

5 Click Save to save the changes.

Note:  If you make any changes to the axis settings and save the changes, you 
can revert to the previous settings by clicking Load.
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